Despliegue de Heroku fallido: maestro -> maestro (gancho de pre recepción rechazado): error: error al empujar algunos refs

Copié una aplicación existente en un nuevo repository. Funciona localmente. Despliega el trabajo para el original. Estoy usando PHP, Yii y Composer. No sé qué es fxp/composer-asset-plugin .

 C:\Users\Chloe\workspace\affiliotwig>git push heroku master Counting objects: 699, done. Delta compression using up to 8 threads. Compressing objects: 100% (655/655), done. Writing objects: 100% (699/699), 25.36 MiB | 142.00 KiB/s, done. Total 699 (delta 146), reused 0 (delta 0) remote: Compressing source files... done. remote: Building source: remote: remote: -----> PHP app detected remote: -----> Bootstrapping... remote: -----> Installing platform packages... remote: - php (5.6.20) remote: - ext-gd (bundled with php) remote: - ext-mbstring (bundled with php) remote: - ext-soap (bundled with php) remote: - nginx (1.8.1) remote: - apache (2.4.20) remote: -----> Installing dependencies... remote: Composer version 1.0.0 2016-04-05 13:27:25 remote: Loading composer repositories with package information remote: Installing dependencies from lock file remote: - Installing fxp/composer-asset-plugin (v1.1.2) remote: Downloading: 100% remote: remote: Plugin installation failed, rolling back remote: - Removing fxp/composer-asset-plugin (v1.1.2) remote: remote: remote: [ReflectionException] remote: Class Fxp\Composer\AssetPlugin\Repository\NpmRepository does not exist remote: remote: remote: [ErrorException] remote: Declaration of Fxp\Composer\AssetPlugin\Repository\AbstractAssetsRepository::whatProvides() should be compatible with Composer\Repository\ComposerRepository::whatProvides(Composer\DependencyResolver\Pool $pool, $name, $bypassFilters = false) remote: remote: remote: install [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--no-plugins] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--ignore-platform-reqs] [--] []... remote: remote: remote: ! Push rejected, failed to compile PHP app remote: remote: Verifying deploy... remote: remote: ! Push rejected to affiliotwig. remote: To https://git.heroku.com/affiliotwig.git ! [remote rejected] master -> master (pre-receive hook declined) error: failed to push some refs to 'https://git.heroku.com/affiliotwig.git' 

Esto está en mi composer.json si es importante

 "require": { "fxp/composer-asset-plugin": "^1.0", 

Tuve que correr

 composer global require fxp/composer-asset-plugin --no-plugins 

luego composer update , luego confirma, luego presiona. Pasó esa parte.

 remote: - Installing fxp/composer-asset-plugin (v1.1.3) remote: Downloading: 100% 

Se rompió nuevamente y tuve que eliminar vendor/ y composer.lock . Puede eliminar el complemento global con el composer global remove "fxp/composer-asset-plugin" . Alguien también dijo que puedes usar rm -r ~/.composer . Mientras tanto, estaba dando un error diferente. Por alguna razón, incluso si tiene "fxp/composer-asset-plugin": "*", en su sección require de composer.json , simplemente no lo carga. Así que tuve que ejecutar ‘global require’ nuevamente para instalar ese misterioso paquete globalmente, y luego pude ejecutar la composer install para que todo estuviera actualizado y funcionó.