“Error fatal: clase no encontrada en …”, no se reconoce el paquete Composer

Realicé esta llamada en Putty , se instaló con éxito el recurso:

 php composer.phar require --dev "mikehaertl/php-pdftk:*" 

Luego agregué un par de cosas a mi composer.json . composer.json :

 { "name": "you/bootstrap-canvas-wp", "type": "wordpress-theme", "require": { "composer/installers": "~1.0" }, "require-dev": { "mikehaertl/php-pdftk": "*" }, "extra": { "installer-paths": { "wp-content/themes/bootstrap-canvas-wp/": ["type:wordpress-theme"] } } } 

A continuación, ejecuté un comando de update en mi archivo de compositor:

 php composer.phar update 

Tengo un archivo ubicado dentro de esa carpeta de temas /public_html/wp-content/themes/bootstrap-canvas-wp que tiene este código:

 use \mikehaertl\pdftk\Pdf; $pdf = new Pdf('mypdf.pdf'); $pdf->flatten() ->saveAs('mypdf2.pdf'); 

Finalmente, puse este fragmento de código en mi archivo functions.php dentro de la carpeta del tema en un esfuerzo por hacer que estas clases sean utilizables:

 require_once(ABSPATH. '../vendor/autoload.php'); 

Mi editor de código reconoce estos recursos, pero obtengo un error en mi navegador:

Error fatal: Clase ‘mikehaertl \ pdftk \ Pdf’ no encontrada en /home/myusername/public_html/wp-content/themes/bootstrap-canvas-wp/flattenPDF.php en la línea 1

¿Alguna sugerencia sobre cómo hacer esto funcional?

EDITAR : También he probado esta syntax para la statement de use : (ocurre el mismo error)

 use mikehaertl\pdftk\Pdf;