Ruta especificada –php_executable_path no existe – GAE php HelloWorld

Configurar el entorno limitado de GAE de PHP en mi computadora portátil Linux (ejecutando los paquetes más recientes de Debian ‘Wheezy’ de 32 bits). La instalación se realizó siguiendo las instrucciones de ‘Instalación del SDK’, seguida de un bash en la aplicación ‘Getting-Started> Hello World’, siguiendo las instrucciones.

Sin embargo, cuando visito http://local.host.com:8080 *, aparece el siguiente mensaje, en lugar de ‘Hello World!’:

The path specified with the --php_executable_path flag () does not exist. 

* Nota: SO no permite que la URL apunte a localhost, ¡entonces lo reemplazó con local.host.com! No es un error

En la consola donde había iniciado el app_server, veo el siguiente mensaje de error:

 ERROR 2014-04-29 03:34:36,219 php_runtime.py:223] The PHP runtime is not available Traceback (most recent call last): File "/home/icarus/google_appengine/google/appengine/tools/devappserver2/php_runtime.py", line 219, in new_instance self._check_environment(php_executable_path) File "/home/icarus/google_appengine/google/appengine/tools/devappserver2/php_runtime.py", line 148, in _check_environment 'flag (%s) does not exist.' % php_executable_path) _PHPBinaryError: The path specified with the --php_executable_path flag () does not exist. 

Tenga en cuenta que he instalado el último php-5.4.27 (instrucciones de php-5.4.25, pero luego continúo para decir en una NOTA que podemos obtener lo último del sitio web de PHP), y lo creamos en mi máquina, exitosamente según las instrucciones.

Es el php-5.4.25 codificado en cualquier lugar, st no se encuentra, ya que en mi máquina tengo php-5.4.27? Esto es lo que veo:

 $ ls -l ~/php-5.4.27/installdir/bin/php-cgi -rwxr-xr-x 1 icarus icarus 23195302 Apr 28 22:58 php-cgi 

Python instalado es 2.7.3, y el SDK de google_appengine es el último estable, es decir, 1.9.3.

Argh … Ignoré para ver la plétora de preguntas que ya estaban en SO, sobre este (o casi este) tema, la mayoría tal vez de principiantes como yo.

En base a esta otra pregunta de respuesta SO, comencé el SDK de esta manera:

 $ google_appengine/dev_appserver.py --php_executable_path=php-5.4.27/installdir/bin/php-cgi work/gae_apps/helloworld/ 

y finalmente ‘¡Hola Mundo!’ funcionó como se esperaba Tal vez, esto requiere un poco de aclaración / elaboración en la página de ‘Inicio’.